MyAmp is being blocked

Incident Report for AMP Platform

Resolved

The issue has been resolved. Users are now able to access MyAmp.
Posted Sep 25, 2026 - 09:29 EDT

Identified

Issue
We are aware that some users access to MyAmp is currently being blocked. Some users are receiving a Website Blocked error message when attempting to log in. The issue is being investigated.
Posted Sep 25, 2026 - 09:22 EDT
This incident affected: AMP Learning (MyAMP).