IXL Canvas Integration

Incident Report for AMP Platform

Resolved

The Canvas IXL integration has been fixed. This issue is now resolved.
Posted Jul 21, 2026 - 10:14 EDT

Identified

We have been made aware that users are unable to access IXL through the Canvas Integration. 

This issue has been escalated to our vendors and there is currently no estimated time of repair. There is no workaround at this time.
Posted Jul 15, 2026 - 16:19 EDT
This incident affected: AMP Learning (3rd Party Curriculum).